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Interface view
1.1 Project Explorer
shows your active projects, project files, which have been included in these projects.
1.2 Properties tab
shows your project name, path to the project files, project type.
1.3 Opened files
show the files currently opened in MAStudio.
1.4 Output

shows Assessment process. Information starts output here after running the Assessment by clicking on the "Start
Assessment" button.

1.5 Search Rules Tree

shows by which of the search rules relevant information was found.
1.6 File Path

shows the file name in which information was found by search rules.
1.7. Occurrence Text and Position

show objects and positions of these objects in the files which was found by search rules.



2. Project creation

To create a new project switch to the tab File -> New -> Project.
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Depending on the project direction, move to the relevant tab and select the appropriate item from the list. Project
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direction can be either "Application" or "Database".

"Application" project works with your scripts, source code files, etc. For example, .cpp files, .cs files, .cob files.

"Database" project works with definition of the objects of your database. For example, .sql files.

On the New Project tab select your direction. A lot of directions of Application project are divided into subgroups. For
example, for Java it can be Hibernate, JSF, Common Java, etc. Directions of Database project type are represented in

one group.
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1El" Application
- Java
C+ +
- Microsoft MET
Wisual Basic
-~ COBOL
- PowerBuilder
- Pascal
- Delphi
- Python
- Perl
- Progress 4GL
 Informix 4GL
= Unix Shell
2 - Databaze

Project templates

Template description

Please choose a project template.

Project name: I

Project path: IC:‘n.Users‘n.roman.shirkn‘n,Documents‘n,lspirerw.ﬂsmdio‘n,

Default |

QOutput path: IC:‘n,Users‘n,roman.shirkn‘n,Documents‘n,lspirerw.ﬂsmdio‘n,‘npumut

Y
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o | ot |

1 — Application project, 2 — Database project

It is also necessary to specify Project name and change default paths to Project folders if you want.




3. Working with a project
3.1.Search rules

In MAStudio the search rules are regular expressions used for search in files and counting of statistics such as objects
found by these search rules, total lines of code in these objects.

You could see your current Search Rules.

For this purpose: right click on your Project Name and select “Search Rules”.
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1 —Search rules group, 2 — Search rule name, 3 — Regular expression of search rules

Here you can find regular expressions which are used for search.



3.1.1. Groups

Search rules can be added to groups, subgroups in MAStudio. The example is on the image above

3.1.2. Search rule options

The following actions can be performed upon a search rule: add a new rule, change the existing rule, delete.
3.1.3. Adding new rule

New rules can be added to a group of rules, or a new regular expression can be added to the existing rule. In the
second case the search will be conducted by two rules at the same time.

Let’s consider two cases:

1) Inorderto add a New Rule right click on the name of the group and choose “Add” -> “New Target”. “Target” is
the name of a search rule.
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Let’s create a new Target named TEST. In order to add a regular expression to this search rule, right click on the search
rule name (TEST) and choose “Add” -> “New rule”.).
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In the added line write down the regular expression by which the search will be conducted.



= Ta ri et TEST

-- Targets DhAL

[+ Targets Working with XML
-- Targets Functicns

[+ Targets System tables

-- Targets Hierarchical queries
[+ Targets Dynamic SOL

-- Targets Other cases

[+ Targets Packages

This way a new search rule can be added.

2) If the object found by a search rule has several kinds (kinds of spelling). Several small regular expressions can be
used instead of a bulky one. In order to add the second regular expression to a search rule, right click on the
search rule name (TEST) and choose “Add” -> “New Rule”. This way the second search rule can be added.

3.1.4. Editing rule

For this right click on the corresponding search rule and change its regular expression.

= T.ar_iet TEST

" Targets DhAL © Add '
- Targets Working with XML

[+ Targets Functicns X Remove
[+ Targets System tables =f

-- Targets Hierarchical queries
[+ Targets Dynamic SQL

[+ Targets Other cases

[+ Targets Packages

3.1.5. Removing rule

”

For this right click on the corresponding search rule and choose “Remove”.
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3.1.6. Default search rules and default levels

MAStudio has two levels of search rules at any of which there is a possibility to bring the default settings back.
1. If you want to bring the default search rules back only at this level, right click on the project, choose “Search
Rules”, and press “Default” and “Apply” buttons. From this time on all the search rules will be changed to
those stored in “config” folder, which you can find in \Documents\user\Ispirer\MAStudio\config)

These are the rules which are used in a new project and can be changed by a user.

2. Inorder to change the default search rules choose the “Options” tab.
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Then choose “Templates”. The tree with the files of templates used upon a new project creation will be opened. The
rules can be changed here, and they will be default rules upon a new project creation.

This level should be used if you have changed default project templates and want to bring the default search rules
back. In case any search rule has been changed here, it will be the same for all the projects created in future. By
clicking on “Default” here, you will change the rules set by you for all the templates to default rules, which were set
during the installation.

3.1.7. Add tab

The files by which the analysis will be conducted should be added to each project for analysis. You can either create
a new file and add your code into it, or add the existing one.

3.1.8. Existing...

In order to add Existing File, File Folder, or Project, right click on Project, choose Add, and then choose “Existing file”,
“Existing Folder”, or “Existing Project”. The corresponding files will be added to the project.
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3.1.9. New...
When choosing “New” an empty file can be created where the code for analysis can be added.

“o|Z e Start Assessment F5
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m [} Existing File... Alt=Shift+A
% Remove De| g Exsting Folder..
Ef Rename E2 Existing Project... Ctrl+Shift+0
P= Open Project Folder B New File Ctrl+Shift+A
pened File B2 Open Output Folder Ca Mew Filter
T ViewReport File New Project... Ctrl-+Shift+N

4" Properties

3.2.Project Folder

This is the directory where the project and all the project files are stored. This option can be changed while creating
the project.

3.3.0utput Folder

After starting the “Assessment” the information about the objects found with the help of search rules is stored in
this folder. It also stores the report, the same as the one that was shown in the main window of MAStudio.

This directory can be changed in the Project Properties. For this right click on the Project Name, choose Properties,
switch to the “General” tab and set a new path to Output Folder.

enerat

Search Rules*®

Project Mame: I oracle

Project Type: I Database\Oradle

Cutput Path: I Ci\Usersroman. shirko\Documents\Ispirer MAStudio\orade YOutput!,

3.4.Report File

The report displays the information about the objects found with the help of search rules such as the number of
lines, the number of found cases, in how many files of the project the objects were found by this search rule or with
the help of this search rule.

The report also displays the information on the files of this project such as the files by which the search was
conducted, the number of files, the number of lines in each file, the size of a file.



3.5.Project properties

It is possible to go to this Project Properties by right clicking on the project. Here the work with search rules can be
performed, and such options as Project Name, Output Path and SQL_DELIMITER can be specified on the “General”
tab.

SQL_DELIMITER is specified by default with regard to standards of each base, if it differs from delimiter in your
“.SQL” scripts, then it must be changed in your project. Without correct SQL DELIMITER search errors and incorrect
work of the Assessment can take place.

4., Assessment stage

After all the options are set and the files that will be involved in the Assessment are added to the project, press
“Start Assessment”.

After pressing, the statistics starts to be collected with the help of xprs.exe (search tool).

While performing the Assessment the information is displayed in the “Output” window.

Qutput F X
———————— Aszszessment started: Project: oracle, Type: Database‘\Oracle -------- -
Start timestamp: Fri May 28 12:35:84 2816
[Occur] "Objects/CREATE PROCEDURE™ "D:\Roman.Shirkoyjob\SQL_Scripts\ORA_SMALL_TEST.sql" (6,300
[Qccur] "Objects/CREATE PROCEDURE"™ "D:%\Roman.Shirkoi\job\SQL_ScriptsWORA_SMALL_TEST.sgl"™ (45,3 ):
[Occur] "Objects/CREATE PROCEDURE™ "D:\Roman. ShirkoyJob\SQL_Scriptsy\ORA_SMALL_TEST.sql" (82,3
[Count] "Objects/CREATE PROCEDURE"™ "D:%\Roman.Shirko\job\SQL_ScriptsWwORA_SMALL_TEST.sgl"™ 3
[Occur] "Objects/TEST"™ "D:\Roman.Shirko\job\SQL_Scripts\ORA_SMALL_TEST.sgl" "(2,5):(2,8)"

[Qccur] "Objects/TEST" "D:%wRoman.Shirkoyjob\SQL_ScriptswORA_SMALL_TEST.sgl"™ “(z2,9):(2,12)"
[Occur] "Objects/TEST"™ "D:\Roman.Shirko\job\SQL_Scripts\ORA_SMALL_TEST.sql" (2,13):(2,22)"
[Qccur] "Objects/TEST" "D:i%wRoman.Shirkoyjob \SQL_ScriptswORA_SMALL_TEST.sgl™ Y(2,23):(2,27)"
[Occur] "Objects/TEST"™ "D:\Roman.Shirko\job\SQL_Scripts\ORA_SMALL_TEST.sql" "(2,28):(2,35)"
[Cceur] "Objects/TEST"™ "D:\Roman.Shirkoyjob\SQL_Scripts‘\ORA_SMALL_TEST.sgl" "(2,36):(2,42)"
[Occur] "Objects/TEST"™ "D:\Roman.Shirko\job\SQL_Scripts\ORA_SMALL_TEST.sql" "(2,43):(2,58)"
[Oceur] "Objects/TEST" "D:\Roman.Shirko\job\SQL_Scripts\ORA_SMALL_TEST.sql" "(4,1):(4,4)"
[Occur] "Objects/TEST"™ "D:\Roman.Shirko\job\SQL_Scripts\ORA_SMALL_TEST.sql" "(4,5):(4,11)"
[Occur] "Objects/TEST"™ "D:\Roman.Shirko\job\SQL_Scripts\ORA_SMALL_TEST.sql" "(4,12):(4,15)"
rOlccur"I "Obiects/TEST" "D:%wRoman.Shirkeviob\SOL Scripts“ORA SMALL TEST.sal"™ "{E.30: fj.Q‘J" f
4 »

After the Assessment is finished the report with information on the objects found by search rules will be displayed
on the screen.

MAStudio General Report

Generated by  Ispirer Systems xprs search tool
Frillay 20 12:35:04 2016

Project name: oracle
Project type: Database\Orack
Project path: C:\Users\roman.shirko\Documents\spirerMAStudioloraclel

Output path: C: shirko\Doc tudio\oracke\Outputi

Assessment time: 00:00:00.226
Matching Files Information
Target Path Lines of Code Files Matched Occurences Found

Objects/CREATE PROCEDURE 93 1 3

Obiects/TEST 339 1 339

OML/UPDATE 15 1 5

[ouCsvs rercirsor E 1 3

Packages/DBMS OUTPUT/ENABLE 3 1 3

OQUTPUT/PUT LINE 5 1 5

Packages/DBWS OUTPUT/PUT 1 5

Total targets number: 3433
Total occurrences number: 383

Searched Files Summary Information

[ File Extension [ Files Number [ Total LOC [ Total Size (bytes) |
[rsal [ | 10| 2359|

Total extensions number: 1
Total files searched: 1

Total files LOC number: 110
Total files size (bytes): 2859




The same information will be displayed in the “Search Rules Tree” window, but it will differ as this window displays
the information in any case, even if nothing has been found by this search rule. By left clicking on the group of rules,
the information on all found similar objects will be displayed in the “Occurrence Text” window. By double left
clicking on one of the objects, it will be shown in the file.

Statistics (Rules) g x

Search Rules Tree f- 3 File Path Tl o# Occurrence Text Position
& S-.“’é:.ﬂu'e‘ 333 D4\Roman.Shirke\job\SOL_Scripts\ORA_SMALL_TEST.sq| MV_LIST 5¥5_REFCURSOR; (9.1:(9.23)
“ Objects .
oL e MV_LIST SVS_REFCURSOR: 874823
MV_LIST SYS_REFCURSOR; (85,1):(95,23)

Lo

~ SELECT INTQ
~ INSERT

- UPDATE

- DELETE

- CURSOR

=+ Working with XML

- XMLAGG

- XMLCONCAT
- XMLELEMENT
- XM FORFST

Statistics (Rules) | Statistics (Fies) |

e oo
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5. Information from the report

MAStudio General Report

Generated by ® Ispirer Systems xprs search tool
Tue May 17 13:28:29 2018

Project name: oracle

Project type: Database\Oracle
Project path: C:
Output path: C Outputi
Assessment ime: 00:00:00.177

Matching Files Information

[ Target Path Lines of Code Files Matched Occurences Found

[Obiscts/CREATE PROCEDURE E2) 1 3
[DML/UPDATE 15 1 5
IDML/SYS REFCURSOR 3 1 3
Packages/DBNS OUTPUTENABLE 3 1 3
Packages/DBNS OUTPUT/RUT LINE E 1 E
[Packages/DBIS OUTPUT/RUT E 1 E

Total targets number: 3437

Total occurrences number: 24

‘Searched Files Summary Information
[ File Extension [ Files Number [ Total LOC [ Total Size (bytes)
F sal [ 1][ 1] [ 2859

Total extensions number: 1
Total files searched: 1

Total files LOC number: 110
Total files size (bytes): 2859

The report stores the information on the objects found by search rules. You can see it in “Matching Files
Information”. For each group of objects there is corresponding information on the number of lines, in how many
files they have been found, the number of the found objects.

Upon clicking on the group of objects, it will be opened, and all the found by this search rule objects will be shown.
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The files which took part in the Assessment are shown in the report section “Search Files Summary Information”, as well
as the corresponding to them information such as the number of files, the number of lines of code in these files, and the

total size of the files.

Also after the Assessment is finished html version of this report is created. You can find it in the “Output” folder situated
in project directory, or right click on project and choose “View Report File”.

6. Project example

[=} __ora
- [2)  p Start Assessment  F5

e ﬁ proc
Search Rules...

© Add

¥ Remove
Eﬁ Rename

P= Open Project Folder
Opened Files P~ Open Qutput Folder

Del

View Report File

& oraclen
Properties

Let’s consider the example of the course of the process.

At first, let’s create project on the basis of the templates. In our case it is the project on statistics collection from Oracle

database .SQL script.

"Il

(A New Project
Template types Project templates Template description
=l Templates ADABAS = || A project for assessment of Orade
£l Application Amazon Aurora
- Java Tibero
Ces FileMaker
. Splice Machine

+ Microsoft NET Amazon Redshift

- Visual Basic MariaDB

- PHR Microsoft SQL Server

-~ ASP

- COBOL IBM DB2 for Linux, UNIX and Windows

PowerBuilder IBM DB2 for iSeries and AS/400 b

IEM DB2 for z/05 and 05/330

+ Pascal SAP HANA

- Delphi HIRDE

- Python MNeoview

- Perl HP NonStop SQLMYX

- Progress 4GL Vertica Analytic Database

- Informix 4GL Teradata
MySQL

- Unix Shell Ingres

Database PostareSOL ~

4 f | »

Project name: Imasmdin_nrade_example

Project path: IC:Wsers\roman.shirko‘\Dou..lmems\lsDirerWASmd\o\masmd\oforadefexample

COutput path: IC:\J.Jsers\roman.shirko\,Domments‘,lspirerw.ﬂStud\o\rnasmd\o_orada_example\oumut

Default

ey
oy
Canca




A pre-compiled “.SQL” script joins the project.

P Start Assessment F5

Search Rules...

m =Y Eisting File... Alt+Shift+ A

% Remove Da  [Eg Exsting Folder..
E‘_ﬁ Rename F2 (& Existing Project... Ctrl+Shift+0
P~ Open Project Folder (b MNew File Ctrl+Shift+A
P~ Open Output Folder Eg Mew Filter

View Report File Mew Project... Ctrl+ Shift+ N
f‘ Properties

Let’s regular expressions of search rules in our example stay default. SQL_DELIMITER option in our example is “/”, as
the descriptions of the objects in our script are separated by this delimiter.

General

Search Rules —Generak

Project Name: | mastudio_orade_example

Project Type: | Database\Oracle

Output Path: | C:\Users'roman. shirko\Documents\Ispirer\MAStudio \mastudio_oracle_example\Output),

—Macros:

5QL_DELIMITER |/ SGL Delimiter

Let’s run the Assessment. After the Assessment is finished, the report with information on this course of the
Assessment process is displayed on the screen.

MAStudio General Report

Generated by @ Ispirer Systems xprs search tool
FriMay 20 13:52:36 2016

Project name: mastudio_oracle_example

Project type: Database\Oracle

Project path: C:\l )_oracle_example\
Output path: C:\L hir i io_oracle_example\Outputh
Assessment time: 00:00:00.175

Matching Files Information

Target Path Lines of Code Files Matched Occurences Found
Obiects/CREATE PROCEDURE 93
DMLUPDATE 15
DML/SYS REFCURSOR

3
Packages/DBMS OUTPUT/ENABLE 3
Packages/DBMS OUTPUT/PUT LINE 5
Packages/DBMS OUTPUT/PUT 5

enlenf el cllon]le

Total targets number: 3437
Total occurrences number: 24

Searched Files Summary Information

[ File Extension [ Files Number [ Total LOC [ Total Size (bytes) |

[Lsal [ | 0] 2&59|

Total extensions number: 1
Total files searched: 1

Total files LOC number: 110
Total files size (bytes): 2859




